irc ignore list in irssi config

Once in a while you’ll get users on community support channels which may flood your private queries with support questions – even if told not to do so (ignorance is bliss, eh?). The simplest way is still /ignore but i prefer to have it globally configured in irssi.

$ vim .irssi/config

ignores = (
        { mask = "MosquitoCR";   level = "ALL"; },
);

Silence … ikillu! 😉

privacy settings on linkedin

Social media networks like Facebook are all about sharing your personal data – and in order to achieve that, the privacy settings are changed on a nearly-monthly basis. At least I am under the impression that every new or changed setting adds yet another option to share more than you actually want.

I was wondering why my linkedin profile was suggesting my gmail contacts as possible members – with their mail addresses. I never gave permission to actually grab that data from gmail, so why the heck are they are now retrieving data from external applications?!?

Well, the answer is simple – new privacy control settings, hidden within the currently 4 categories “Profile”, “Communications”, “Groups, Companies & Applications” and “Account”. Watch out for these 3 marked in the screenshots.

linkedin_privacy_settings_01

 

linkedin_privacy_settings_data_sharing_3rd_partylinkedin_privacy_settings_data_sharing_plugins

 

And the account advertising

 

linkedin_privacy_settings_02

 

linkedin_privacy_settings_accounts

 

 

Hooray for the next privacy control “enhancements” – just wait for it.

disable what's hot in google plus stream

I’m not really the biggest google plus user, but i really like to filter information, especially only what is of interest to me. Lately, Google decided to add random “What’s hot on Google+” to your stream, which is basically sort of “trending on twitter” within Google+ – to tell facebook-wise – DISLIKE!

Luckily you can disable that by going to “Explore” and then drag the selection to the left, removing all what’s hot from your stream. LIKE!

disable firefox url guessing feature

Firefox currently offers the possibility to automatically add ‘www’ as URL prefix – so called ‘URL guessing feature’. Regarding the different behavior on DNS resolving (www vs @ zone record), this is rather annoying.

To turn that off, open a new tab and type about:config and search for browser.fixup.alternate.enabled. Doubleclick it to disable it and close the tab.

qwit with working oauth for twitter

Twitter changed their auth mechanism a while ago, disabling basic auth and insisting on oauth. SVN revision 353 (1.1-pre2) reflects those changes in qwit, but as a matter of fact pending packages. They are in Debian sid already – but *Ubuntu still supplies the old 303 revision (1.0)

Since Debian packages can be used on *Ubuntu too (only if they do not have too much dependencies, and qwit only demands qt4 in 1.0) I gave that a try – because without oauth support, qwit remains useless.

Problem: New dependency on libqoauth1 – which is for gods sake provided in debian sid too. Get both debs and install that package manually – qwit and Twitter working again!

$ wget http://ftp.at.debian.org/debian/pool/main/q/qoauth/libqoauth1_1.0.1-1_amd64.deb http://ftp.at.debian.org/debian/pool/main/q/qwit/qwit_1.1+svn353-1_amd64.deb

$ sudo dpkg -i libqoauth1_1.0.1-1_amd64.deb qwit_1.1+svn353-1_amd64.deb

Thunderbird and mail reply formatting

I’ll admit it, I really like that when i click “reply to …” then a new window pops up and the composition is set to “fixed width” on HTML, just to see everything being seperated with color. So I am just using the HTML view with monospace fixed width composed emails.

The thing I really hate with Thunderbird is the fact that getting the cursor at the end of a quote, pressing enter, creating a new line feed – getting from fixed width onto variable width – wtf is going on over there?

In “Edit” – “Preferences” – “Composition” there is “HTML – Font” being set to “fixed width” instead of “variable width”. That does not really affect the situation when Thunderbird decides that it will be using “variable width” instead of my decision. I could press Ctrl+A and set the dropdown menu to “fixed width” again, but that kind of sucks.

The real problem is not the HTML fonts being used, or the HTML format either. In the preferences window, switch to the “Display” and “Formatting” tab. You will recognize that the “default font” is set to “serif” with size 16.

Setting that to “monospace” with size 12 resolves the problem and replying to emails with the correct view even with HTML is much more fun 🙂